LG G Forum - The #1 LG G6, G5, G4, G3 & G2 News, Discussion and Fan Site!

LG G2 Discussion Forums => G2 Help => Topic started by: teemcoil on January 21, 2014, 01:27:07 AM

Title: Unable to send MMS messages
Post by: teemcoil on January 21, 2014, 01:27:07 AM
Whenever I try to send a text w/ an attachment on my LG G2, regardless of its size, it fails to send. If I'm using the 4G LTE network, after about a minute the attachment is 'x'ed out, and its status reads "Unsuccessful". If I'm using WiFi, the status hangs on "Pending". I've read that sometimes it's just the WiFi, so from these results I don't think it's just the Wifi.

After Googling around for some advice, the most effective solution I've seen is to set up an APN with the following settings:

Name: Verizon
APN: internet
Proxy: blank
Port: blank
Username: blank
Password: blank
Server: blank
MMSC: http://mms.vtext.com/servlets/mms (http://mms.vtext.com/servlets/mms)
MMS Proxy: blank
MMS Port: 80
MCC: 310
MNC: 012
Authentication type: blank
APN Type: internet + mms
APN Protocol: IPv4
APN Roaming Protocol: IPv4
APN Enabled
Bearer: Unspecified

Unfortunately when I try to save an APN with these settings, it doesn't appear on the list of available APNs. Additionally, if I edit a random APN that I made up and replace its settings with the ones above, then that APN will disappear from the list after saving.

Does anyone know of any other options that I could try out to resolve the issue? Or does anyone know why I'm unable to create an APN with the settings above?

Thanks, Tim
Title: Re: Unable to send MMS messages
Post by: Klotar on January 21, 2014, 07:42:29 AM
A few thoughts:

- Are you on a plan that includes MMS?  While to us, SMS and MMS are similar except MMS includes multimedia (pics/vids), they are very different in how they work.  On Rogers in Canada, it used to be that on certain plans, you could send/receive SMS but MMS was extra; however, this was a few years back, most carriers now include both.

As a FYI, when you are on Wi-Fi, it replaces your *DATA* connection but even while connected to Wi-Fi, your calls, SMS and MMS are sent over the cellular network (unless you are on a carrier that has UMA or Wi-Fi Calling (only T-Mo, Rogers and Cincinatti Bell have this in North America).  That said, do you typically have a good cellular connection at the time you are sending these MMS's?

- You mention that you are on Verizon, is your G2 a Verizon branded G2?

- Have you tried rebooting the phone (shutting down and restarting)?

I thought I would eliminate these before moving on.

MMS generally has an attachment size limit.  I am not sure what that size limit is, and it may vary by carrier.  How large are the pictures you are trying to send, were they taken on the G2 at maximum resolution (13 mp)?  Is the person you are sending the MMS to on the same carrier (Verizon) as you?  Both the sending carrier and receiving carrier MAY have size limitations.

As an experiment, you should try either sending a picture taken at lower resolution OR a picture downloaded off the internet of a known, small, size (like an avatar icon).  If it works, then we have narrowed down the issue somewhat and can take it from there by experimenting with resolutions and sizes.

How are the pictures being sent, do you send it directly from the camera app, view it first from the gallery and then share or send?  I am not sure offhand, but I think when you send media via MMS, depending on where you are on the device when you send it, you have the option to send the picture/video at varying sizes/resolutions.  That is, the device will "convert" (downsize) the resolution to make it suitable for sending via MMS.  Or, there is a checkbox setting somewhere that may need to be unchecked next to Preserve Original Size (or something like that).

Let's start there and we can try to take it further if you've tried sending smaller pics and have rebooted and still have no success.

PS - I know you said regardless of size but didn't specify the size.  So I mean try a pic that is very small (like an icon) like a few hundred k, and if it doesn't go through, it will confirm it's definitely not a size issue (not that I doubt you, but you didn't say -- and a 4 MB pic and a 5 MB pic might both be too big, especially across carriers).

Title: Re: Unable to send MMS messages
Post by: teemcoil on January 21, 2014, 01:34:30 PM
Thanks for the reply. To answer your questions:
Yes, I am on a plan that includes MMS.
Yes, when sending the MMSs I have a healthy cellular connection.
Yes, my G2 is a Verizon branded G2.
Yes, I've tried rebooting the phone. I tried once more just now for good measure.

The people I've tried sending MMS to are on the same carrier as me, yes. The photos I tried sending before ended up being ~800 KB. Sending them directly from the Gallery or from the "Attachments" screen in the texting window has the same result. The photos are compressed if they exceed the size limit (which seems to be 1200 KB). I tried a smaller photo per your suggestion (< 300 KB), but it was unable to go through.

Title: Re: Unable to send MMS messages
Post by: Klotar on January 21, 2014, 04:32:20 PM
Okay, sounds like you are very knowledgeable and have approached this in a logical manner.

I found a thread on the Verizon forums, not specific to the G2 to some of it may apply:


If interest (things to try or look into) are in there but I think you covered most.  One that sounds promising (but a pain) is asking Verizon to reprovision your MMS.  The thread starts out with Wi-Fi discussion but may become applicable farther in.

A few promising ideas here too:


I've had an issue before that I spent a lot of time on, tried a multitude of things to no avail, and it's ended up being somehow my settings being mixed up on the carrier side before.  I had called them in bitter defeat only to end up that they reset me on their side and it fixed everything.  Not saying that's it in your case but sounds like you've tried everything.

Last few desperation suggestions are to try a 3rd party SMS/MMS app... er, which reminds me, you don't have Google Hangouts installed, do you? 
Title: Re: Unable to send MMS messages
Post by: teemcoil on January 21, 2014, 07:38:05 PM
Google Hangouts did come pre-installed on the phone, but I removed it in favor of the default messaging system. Thanks for your effort. After trying advice from other websites and yourself, there didn't seem to be anything that would work, apart from 3rd party software. I've since called Verizon and they ended up resetting a few things for me. I'm now able to send/receive MMS.

Thanks again,
Title: Re: Unable to send MMS messages
Post by: Klotar on January 21, 2014, 09:40:46 PM
Great news, glad you got it resolved -- and thanks for reporting back.